Scheduled Maintenance
Incident Report for ysendit.com
Resolved
Maintenance is complete
Posted Apr 11, 2023 - 18:03 CEST
Investigating
Hello! Maintenance work is scheduled from 15:00 GMT+2. This will most likely last until 23:00 GMT+2 and will affect both uploads and downloads.
Posted Apr 11, 2023 - 14:28 CEST
This incident affected: Uploads, Downloads, and Mac app.